Pluie: 0=non 1=oui

Forum destiné aux problèmes de Tags, recherche d’une fonction, d’un calcul, Tag qui parait ne pas fonctionner, du Tag et rien que du Tag !
fdudul
Participation 0
Participation 0
Messages : 13
Enregistré le : 28 oct. 2010, 20:14

Pluie: 0=non 1=oui

Message par fdudul » 15 nov. 2010, 19:02

Bonsoir, Peut-on mettre lorsqu'il pleut ou pas la réponse oui ou non directement à la place de 0 et 1?

merci pour votre réponse.

mm91
Participation 6
Participation 6
Messages : 2494
Enregistré le : 31 mars 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: Pluie: 0=non 1=oui

Message par mm91 » 15 nov. 2010, 21:01

Oui, certainement !

dans la séquence suivante:

%ws_setmem[1]=%ws_replacestr=brumeux*~nuages très épais*~%suntxt%%%
%ws_replacestr=brumeux~nuages très épais~%ws_getmem[1]%%

lorsque le tag %suntxt% donne "brumeux*" le texte est remplacé par "nuages très épais"
tu peux donc faire la même chose avec le tag de présence de pluie.

Je crois que c'est Chriss qui me l'avait fait.
Tu peux essayer et t'amuser un peu,
tu peux aussi attendre une réponse plus précise !
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

fdudul
Participation 0
Participation 0
Messages : 13
Enregistré le : 28 oct. 2010, 20:14

Re: Pluie: 0=non 1=oui

Message par fdudul » 15 nov. 2010, 22:56

Ok merci pour ce début de piste.

mm91
Participation 6
Participation 6
Messages : 2494
Enregistré le : 31 mars 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: Pluie: 0=non 1=oui

Message par mm91 » 15 nov. 2010, 23:47

J'ai fait ça:

%ws_setmem[1]=%ws_replacestr=0~actuellement il ne pleut pas~%raining%%%
%ws_replacestr=0~actuellement il ne pleut pas~%ws_getmem[1]%%
%ws_setmem[1]=%ws_replacestr=1~actuellement il pleut~%raining%%%
%ws_replacestr=1~actuellement il pleut~%ws_getmem[1]%%

mais il y a un "0" en trop à la fin !

voir essai (provisoir) tout en bas de cette page:
http://icare.cinq.free.fr/meteo/courrent.html
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

Avatar du membre
webmaster
Site Admin
Site Admin
Messages : 2611
Enregistré le : 12 déc. 2006, 20:54
Localisation : Rieux 51 FRANCE
Contact :

Re: Pluie: 0=non 1=oui

Message par webmaster » 16 nov. 2010, 08:46

Bonjour,

Pour moi vous cherchez les complication !
Ce tag ne pouvant donner que deux valeurs, il est plus simple de faire une condition sur une seule et unique ligne.

Si tag = 0 il ne pleut pas, dans le cas contraire il pleut.
C'est vrai aussi pour un changement d'image.....
Cordialement

Rieux

mm91
Participation 6
Participation 6
Messages : 2494
Enregistré le : 31 mars 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: Pluie: 0=non 1=oui

Message par mm91 » 16 nov. 2010, 08:54

Certainement !
allez ! encore un petit effort et donne nous directement le tag !
(ce n'est pas très pédagogique, mais ça aide !)
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

Avatar du membre
webmaster
Site Admin
Site Admin
Messages : 2611
Enregistré le : 12 déc. 2006, 20:54
Localisation : Rieux 51 FRANCE
Contact :

Re: Pluie: 0=non 1=oui

Message par webmaster » 16 nov. 2010, 10:08

Admettons:
Déjà un peu de lecture !
http://rieux-marne.net/meteo/wswin/pers ... aison.html

Cela donne:

Code : Tout sélectionner

%ws_compare[1]=%raining%~0~Il pleut~Il ne pleut pas%
Tu peux également remplacer le tag %raining% par %curval[34]%
IL faudra prendre soin dans ce cas de stopper l'affichage de l'unité le temps de la comparaison.
Dans l'exemple ci-dessous j'ai remplacé les mots par des images.

Code : Tout sélectionner

%unit_off%
<img src="%ws_compare[1]=%curval[34]%~0~rain_on.gif~rain_off.gif%">
%unit_on%
Cordialement

Rieux

fdudul
Participation 0
Participation 0
Messages : 13
Enregistré le : 28 oct. 2010, 20:14

Re: Pluie: 0=non 1=oui

Message par fdudul » 16 nov. 2010, 11:20

Bonjour,

Merci pour toutes ces explications, bonne journée

Cordialement F

mm91
Participation 6
Participation 6
Messages : 2494
Enregistré le : 31 mars 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: Pluie: 0=non 1=oui

Message par mm91 » 16 nov. 2010, 21:15

J'ai mis le tag:

%ws_compare[1]=%raining%~0~Il pleut~Il ne pleut pas% actuellement

en essai provisoir(jusqu'à la prochaine pluie) tout en bas de ma page: http://icare.cinq.free.fr/meteo/courrent.html
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

Avatar du membre
chimere32
Participation 2
Participation 2
Messages : 127
Enregistré le : 07 sept. 2009, 17:28
Localisation : Cousances les forges(55) Alt:179m
Contact :

Re: Pluie: 0=non 1=oui

Message par chimere32 » 16 nov. 2010, 22:41

Bonsoir fdudul,

Est cela que tu veux http://meteocousances.perso.sfr.fr/html/current.html ? ou dans le même genre.
Cordialement Jean Claude de la Meuse.
http://meteocousances.perso.sfr.fr/index.html
Image
Rien n'est plus beau que la nature , lorsqu'elle n'est pas envahie par le plus grand prédateur(l'homme).

Avatar du membre
webmaster
Site Admin
Site Admin
Messages : 2611
Enregistré le : 12 déc. 2006, 20:54
Localisation : Rieux 51 FRANCE
Contact :

Re: Pluie: 0=non 1=oui

Message par webmaster » 17 nov. 2010, 10:12

mm91 a écrit :J'ai mis le tag:

%ws_compare[1]=%raining%~0~Il pleut~Il ne pleut pas% actuellement

en essai provisoire (jusqu'à la prochaine pluie) tout en bas de ma page: http://icare.cinq.free.fr/meteo/courrent.html
En test ! J''utilise ce code (avec %curval[34]%) depuis plus de cinq ans.
Il date de l'époque ou nous nous amusions avec Chamois à celui qui en mettra le plus dans son custom, c'est pour dire....

Ce code ne trouve un intérêt que lorsque le pas de relevé est court et surtout que le site est mise à jour sur un pas très rapproché.
Sinon tomber sur un moment où la condition sera fausse tient vraiment de la chance.
Cordialement

Rieux

Avatar du membre
kalimero
Participation 2
Participation 2
Messages : 183
Enregistré le : 25 nov. 2008, 13:54

Re: Pluie: 0=non 1=oui

Message par kalimero » 17 nov. 2010, 10:39

Bonjour MM91

%ws_setmem[1]=%ws_replacestr=0~actuellement il ne pleut pas~%raining%%%
%ws_replacestr=0~actuellement il ne pleut pas~%ws_getmem[1]%%
%ws_setmem[1]=%ws_replacestr=1~actuellement il pleut~%raining%%%
%ws_replacestr=1~actuellement il pleut~%ws_getmem[1]%%

mais il y a un "0" en trop à la fin !


Comment as tu fait pour enlever le "O" a la fin de l'affichage
Cordialement
Alain

Avatar du membre
webmaster
Site Admin
Site Admin
Messages : 2611
Enregistré le : 12 déc. 2006, 20:54
Localisation : Rieux 51 FRANCE
Contact :

Re: Pluie: 0=non 1=oui

Message par webmaster » 17 nov. 2010, 10:59

:surprised: Il faut également lire les autres massages !
Cordialement

Rieux

mm91
Participation 6
Participation 6
Messages : 2494
Enregistré le : 31 mars 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: Pluie: 0=non 1=oui

Message par mm91 » 17 nov. 2010, 11:00

kalimero a écrit :Bonjour MM91

%ws_setmem[1]=%ws_replacestr=0~actuellement il ne pleut pas~%raining%%%
%ws_replacestr=0~actuellement il ne pleut pas~%ws_getmem[1]%%
%ws_setmem[1]=%ws_replacestr=1~actuellement il pleut~%raining%%%
%ws_replacestr=1~actuellement il pleut~%ws_getmem[1]%%

mais il y a un "0" en trop à la fin !


Comment as tu fait pour enlever le "O" a la fin de l'affichage
Cordialement
Alain
salut Alain,
Comme indiqué dans un post précédent, j'ai supprimé ce tag idiot et très compliqué et l'ai remplacé par le tag du webmaster:

%ws_compare[1]=%raining%~0~Il pleut~Il ne pleut pas% actuellement

qui fonctionne très bien
j'attends quand même la prochaine pluie pour le supprimer du bas de ma page: http://icare.cinq.free.fr/meteo/courrent.html
Il n'y est qu'à titre d'essai provisoir.
Sur cette page on sait déjà s'il pleut avec:
- l'intensité actuelle (0 mm/h s'il ne pleut pas actuellement)
- le temps écoulé depuis la dernière pluie (à "0 minutes" s'il pleut actuellement)
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

Avatar du membre
kalimero
Participation 2
Participation 2
Messages : 183
Enregistré le : 25 nov. 2008, 13:54

Re: Pluie: 0=non 1=oui

Message par kalimero » 17 nov. 2010, 11:10

Merci pour la reponse
je modifie mon tag
A+
alain

Répondre