problème d'arrondi du pas du pluviomètre

Forum destiné aux problèmes de Tags, recherche d’une fonction, d’un calcul, Tag qui parait ne pas fonctionner, du Tag et rien que du Tag !
mm91
Participation 6
Participation 6
Messages : 2547
Enregistré le : 31 Mar 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

problème d'arrondi du pas du pluviomètre

Messagepar mm91 » 04 Fév 2017, 09:58

bonjour,

Mon pluviomètre La Crosse a un pas fixe de 0.518 mm

dans Wswin32 j'ai mis un coefficient de calibration du pluvio de 0.228

Le pas dans Wswin32 devient donc:

0.518*0.228 = 0.118104 mm

Quand j'édite les valeurs de pluie dans Wswin32 je lis bien: 0.118mm

jusque là tout est OK.

mais pour faire un calcul d'intensité de pluie, j'utilise le tag:

%curval[34]% (id 34 étant la valeur pluie)

qui me donne (pour un basculement): 0.1 mm

Le problème c'est que je le multiplie par 12 pour avoir des mm / h
(j'ai un pas de 5 mn; 5*12 = 1 heure, mais mesuré sur 5 minutes)

pour un basculement en 5 mn j'obtiens 1.2 mm / h (0.1*12) au lieu de 1.416 mm / h (0.118*12)

pour 6 basculements en 5 mn l'erreur devient bien plus grande:
j'obtiens 7.2 mm / h (0.1*6*12) au lieu de 8.5 mm / h (0.118*6*12)


Question:
pourquoi %curval[34]% me donne 0.1 mm alors que le pas réel est 0.118 mm ?
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

mm91
Participation 6
Participation 6
Messages : 2547
Enregistré le : 31 Mar 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: problème d'arrondi du pas du pluviomètre

Messagepar mm91 » 12 Fév 2017, 13:00

Je me permets de faire remonter ce post en renouvelant ma question:

pourquoi %curval[34]% me donne 0.1 mm alors que le pas réel est 0.118 mm ?
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

Tudgur
Participation 6
Participation 6
Messages : 1710
Enregistré le : 13 Mai 2007, 16:47
Localisation : 29880 Plouguerneau
Contact :

Re: problème d'arrondi du pas du pluviomètre

Messagepar Tudgur » 12 Fév 2017, 13:33

Salut Michel

Sans doute que persone n'a la réponse !
Peut-être que le tag n'a qu'une précision du 1/10 ième de mm ?
Cordialement.

Tudgur
http://meteo-plouguerneau.fr

mm91
Participation 6
Participation 6
Messages : 2547
Enregistré le : 31 Mar 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: problème d'arrondi du pas du pluviomètre

Messagepar mm91 » 12 Fév 2017, 14:47

Tudgur a écrit :Salut Michel

Sans doute que persone n'a la réponse !
Peut-être que le tag n'a qu'une précision du 1/10 ième de mm ?


Si ton pas (valeur d'un basculement d'auget) a plus d'un chiffre après la virgule (à vérifier avec "Editer / précipitations), peux-tu faire l'essai:

par exemple tu mets provisoirement le tag:

%curval[34]%

dans une de tes pages custom
(comme je fais tout en bas de cette page: http://icare.cinq.free.fr/meteo/courrent.html )

et tu regardes le résultat après calcul.

ou quelqu'un d'autre peut-il faire l'essai ?

merci
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

Tudgur
Participation 6
Participation 6
Messages : 1710
Enregistré le : 13 Mai 2007, 16:47
Localisation : 29880 Plouguerneau
Contact :

Re: problème d'arrondi du pas du pluviomètre

Messagepar Tudgur » 12 Fév 2017, 17:51

Je n'ai que le menu Fichier / Propriétés / Pluviométrie mais pas de réglage possible !
Cordialement.

Tudgur
http://meteo-plouguerneau.fr

mm91
Participation 6
Participation 6
Messages : 2547
Enregistré le : 31 Mar 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: problème d'arrondi du pas du pluviomètre

Messagepar mm91 » 13 Fév 2017, 08:07

Tudgur a écrit :Je n'ai que le menu Fichier / Propriétés / Pluviométrie mais pas de réglage possible !


Je ne parle pas de ça.

Dans "Editer" (5ème icône) / Précipitations"

quelle est la valeur qui apparaît lorsque tu as eu un seul basculement d'auget (à l'heure de ce basculement) ?
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

Tudgur
Participation 6
Participation 6
Messages : 1710
Enregistré le : 13 Mai 2007, 16:47
Localisation : 29880 Plouguerneau
Contact :

Re: problème d'arrondi du pas du pluviomètre

Messagepar Tudgur » 13 Fév 2017, 18:50

Je n'ai pas testé en faisant un basculment d'auget mais voici mon observation :
J'affiche le graphique jour.
Dans Fichier / Editer données météo /Pluviométrie je mets une valeur 0.230 au lieu de 0.000.
En bas du graphique jour, la valeur affichée est 0.2 mm
Cordialement.

Tudgur
http://meteo-plouguerneau.fr

mm91
Participation 6
Participation 6
Messages : 2547
Enregistré le : 31 Mar 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: problème d'arrondi du pas du pluviomètre

Messagepar mm91 » 13 Fév 2017, 19:42

Tudgur a écrit :Je n'ai pas testé en faisant un basculment d'auget mais voici mon observation :
J'affiche le graphique jour.
Dans Fichier / Editer données météo /Pluviométrie je mets une valeur 0.230 au lieu de 0.000.
En bas du graphique jour, la valeur affichée est 0.2 mm


OK,
chez moi aussi les "0.118" se transforment en "0.1" dans la barre des min-max des graphiques; mais c'est seulement un arrondi d'affichage.
Par exemple pour 4 basculements (=0.472 mm) l'affichage sera bien "0.5" (arrondi de 4*0.118)et non "0.4" (=4*0.1)

Mais ce n'est pas ce que je cherche.

Ce que j'aimerai savoir, maintenant, chez toi, c'est ce qui est calculé avec le tag:
%curval[34]% (pour un basculement)
0.2
ou
0.23
ou
0.230
?
Merci
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

Tudgur
Participation 6
Participation 6
Messages : 1710
Enregistré le : 13 Mai 2007, 16:47
Localisation : 29880 Plouguerneau
Contact :

Re: problème d'arrondi du pas du pluviomètre

Messagepar Tudgur » 14 Fév 2017, 18:16

Si je remplace un basculement de 0.200 mm par 0.230 mm, %curval[34]% me donne 0.2 ( et non pas 0.200)
Si je simule quatre basculements successifs de 0.200 modifiés en 0.230, les tags pluie sur 10 min ou 1h me donnent 0.9...
Cordialement.

Tudgur
http://meteo-plouguerneau.fr

mm91
Participation 6
Participation 6
Messages : 2547
Enregistré le : 31 Mar 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: problème d'arrondi du pas du pluviomètre

Messagepar mm91 » 14 Fév 2017, 19:10

Tudgur a écrit :Si je remplace un basculement de 0.200 mm par 0.230 mm, %curval[34]% me donne 0.2 ( et non pas 0.200)

OK, ça c'est donc comme chez moi;
c'est ce que je voulais savoir
merci.


Si je simule quatre basculements successifs de 0.200 modifiés en 0.230, les tags pluie sur 10 min ou 1h me donnent 0.9...

quel est ce tag ?
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

Tudgur
Participation 6
Participation 6
Messages : 1710
Enregistré le : 13 Mai 2007, 16:47
Localisation : 29880 Plouguerneau
Contact :

Re: problème d'arrondi du pas du pluviomètre

Messagepar Tudgur » 14 Fév 2017, 20:38

Pour 10 minutes ; %valuechange[34]=10%
Il y a aussi : %valuechange[34]=30%
Cordialement.

Tudgur
http://meteo-plouguerneau.fr


Retourner vers « tags »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité