Page 1 sur 1

Problèmes de tags avec mise à jour

Posté : 30 Mai 2018, 19:54
par Tudgur
Aujourd'hui 30 mai, je décide de passer de la version 2.97.13 à la toute dernière, 2.99.3.
Pour ce, j'ai procédé d'une façon particulière pour ne pas "perturber" mon PC meteo.
J'ai téléchargé le fichier wswin32_r_en.exe puis je l'ai copié dans une copie de mon dossier WsWin, sur un autre PC.
J'ai renommé mon fichier wswin32.exe en wswin32.exe_old et wswin32_r_en.exe en wswin32.exe.
J'ai ensuite exécuté ce dernier.
Windows m'a mis en garde contre logiciel inconnu mais j'ai continué.
Après différentes étapes d'acceptation et de chemin "d'installation", il faut redémarrer le PC.
Je vérifie après redémarrage, tout semble OK.

Puis, je copie ce nouveau fichier wswin32.exe sur mon PC météo après avoir renommé l'ancien en wswin32.exe_old.
Tout fonctionne OK jusqu’à ce que je me rende compte quelques heures plus tard que mes records de pluie et d'ensoleillement du mois de mai sont faux !!!

Je renomme alors mon fichier wswin32.exe_old en wswin32.exe et je copie ws_hist.txt enregistré le matin même.
Je reviens donc à mon ancienne version et mes records redeviennent bon...

Edit
ws_hist.txt ne semble pas en cause.
J'ai refait la manip inverse, donc utilisé la nouvelle version de Wswin32.exe.(2.99.3)
Même sentence, les deux records sont faux !!!

pb_comparaisons.jpg

Je remets le fichier Wswin32.exe de la version 2.97.13, les records sont bons.

comparaison.jpg

Ai-je raté quelque chose lors de la mise à jour ?

Re: Problèmes de tags avec mise à jour

Posté : 31 Mai 2018, 14:15
par JP22
Bonjour René,

Voir si "valeurs sur long terme modifiées en auto" est coché dans la fenêtre "valeurs sur long terme" des données sur long terme, puis mise à jour de ces statistiques dans "Internet-mise à jour graphiques et tableaux", en bas de la fenêtre cocher "données statistiques".

Cela -normalement- met à jour les stats.

L'autre solution, plus longue est, toujours dans la même fenêtre de remouliner les valeurs en sélectionnant la période, cliquer dans "jour" sur tableau et en bas "données statistiques".

On a des phénomènes bizarres parfois avec wswin...
Pour moi, d'un coup les variables %ws_m_maxval[xxxxx% ne fonctionnent plus sans raison apparente...


Cordialement

JP

Re: Problèmes de tags avec mise à jour

Posté : 31 Mai 2018, 16:10
par Tudgur
Salut JP !

Il ne s'agit pas des valeurs sur le long terme (tags LT....) mais de deux tags qui me donnent, l'un le record de pluie du mois courant, l'autre le record d'ensoleillement du mois courant. (mois courant depuis le début de mesures, donc actuellement mois de mai de 2007 à 2018)

Pour le pluie, ce sont ces deux-ci :
$tab['valeur_pluie_maxi'] = '%ws_cutstr=0~1~%season_monthmax[34~%ws_month2%~2006~%ws_year%S]%%';
$tab['annee_pluie_maxi'] = '%ws_cutstr=5~12~%season_monthmaxd[34~%ws_month2%~2006~%ws_year%S]%%';

Pour l'ensoleillement :
$tab['H_M_ensoleillement_maxi'] = '%ws_valtotime[%season_monthmax[37~%ws_month2%~2006~%ws_year%S]%]%';
$tab['annee_ensoleillement_maxi'] = '%ws_cutstr=5~12~%season_monthmaxd[37~%ws_month2%~2006~%ws_year%S]%%';

Ces tags fonctionnent parfaitement avec la version 2.97.13, à Plouguerneau comme à Puy-Saint-Pierre mais donnent des résultats fantaisistes avec la dernière version, pour les valeurs comme pour les années !