problème avec création du fichier "windbft_current.gif"

Forum dédié aux différents bogues découverts ou aux éventuelles améliorations, peut être que Werner nous entendra !
mm91
Participation 6
Participation 6
Messages : 2543
Enregistré le : 31 Mar 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

problème avec création du fichier "windbft_current.gif"

Messagepar mm91 » 19 Oct 2014, 21:28

J'ai découvert un bug avec la création du fichier:

windbft_current.gif

Dans "Internet / Réglages / Graphique"
j'ai coché:
"Créer graphique pour la distribution des vents en mode enregistrement"
"Direction du vent + force du vent"
"Semaine"
"Jour"

Dans "Meteo / direction du vent/force du vent / affichage"
j'ai coché
"Rose des vent"

Après avoir lancé Wswin32, tout se passe normalement:
à chaque enregistrement sont crées, dans le dossier "html", les deux fichiers de vent:

ddis_current.gif
et
windbft_current.gif

et ces fichiers sont bien transmis sur mon site ici:

http://icare.cinq.free.fr/meteo/ddis_current.gif
et ici
http://icare.cinq.free.fr/meteo/windbft_current.gif

jusque là tout est normal.

Mais je me suis aperçu que dans Wswin32 si j'ouvrais et refermais la rose des vent (avec "Meteo / direction du vent/force du vent ")
dans tous les enregistrement suivants, le fichier
"windbft_current.gif"
était crée avec le dessin de la rose des vent (au lieu du "camembert" avec les forces de vent), c'est à dire comme le fichier "ddis_current.gif"
(mais portant bien le nom " windbft_current.gif")

Ensuit je ne peux revenir à un fonctionnement normal que si je ferme et rouvre Wswin32
(en prenant garde de ne pas refaire "Meteo / direction du vent/force du vent ")

J'espère que j'ai bien expliqué ?

Pouvez-vous essayer de reproduire ce défaut chez vous et me dire le résultat ?

merci


PS
J'avais déjà évoqué ce problème dans le post suivant, mais les hypothèses que j'avais faites alors étaient fausses.
viewtopic.php?f=2&t=1475
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

mm91
Participation 6
Participation 6
Messages : 2543
Enregistré le : 31 Mar 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: problème avec création du fichier "windbft_current.gif"

Messagepar mm91 » 21 Oct 2014, 08:58

J'ai un Wswin32.exe d'essai qui tourne avec la version V2.97.8:
le problème est exactement le même qu'avec la dernière version (V2.97.12) ci-dessus.


Avez-vous fait l'essai chez vous ?
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

mm91
Participation 6
Participation 6
Messages : 2543
Enregistré le : 31 Mar 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: problème avec création du fichier "windbft_current.gif"

Messagepar mm91 » 08 Nov 2014, 08:52

Avant de signaler ce problème à Werner, j'aurai bien aimé savoir si vous aviez pu constater ce bug ?
Ce n'est pas très difficile à faire la manip, avec les réglages que j'ai donné dans mon premier post.

merci à vous
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

Tudgur
Participation 6
Participation 6
Messages : 1710
Enregistré le : 13 Mai 2007, 16:47
Localisation : 29880 Plouguerneau
Contact :

Re: problème avec création du fichier "windbft_current.gif"

Messagepar Tudgur » 08 Nov 2014, 17:01

Bonjour Michel.

J'ai essayé ta manip et je n'ai pas eu ton problème !
Mais chez moi, WsWin s'ouvre automatiquement toutes les 5 min puis se referme...
Cordialement.

Tudgur
http://meteo-plouguerneau.fr

mm91
Participation 6
Participation 6
Messages : 2543
Enregistré le : 31 Mar 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: problème avec création du fichier "windbft_current.gif"

Messagepar mm91 » 08 Nov 2014, 18:00

Merci Tudgur,

Mais que Wswin s'ouvre et se ferme automatiquement ou manuellement ne change rien au problème ici.

Tu peux donc essayer, pendant les cinq minutes ou il est ouvert, de faire la manip:
demande de création des deux fichiers "ddis_current.gif" et "windbft_current.gif",
puis faire: "Meteo / direction du vent/force du vent"
et voir à l'enregistrement suivant (avant que wswin ne se ferme et se ré-ouvre) si les deux fichiers sont crées normalement.

Mais c'est sans doute ce que tu as fait.
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

Tudgur
Participation 6
Participation 6
Messages : 1710
Enregistré le : 13 Mai 2007, 16:47
Localisation : 29880 Plouguerneau
Contact :

Re: problème avec création du fichier "windbft_current.gif"

Messagepar Tudgur » 08 Nov 2014, 20:01

Oui, c'est ce que j'ai fait !
Cordialement.

Tudgur
http://meteo-plouguerneau.fr

Avatar du membre
vals
Participation 5
Participation 5
Messages : 825
Enregistré le : 13 Déc 2006, 20:27
Localisation : 69320 Feyzin
Contact :

Re: problème avec création du fichier "windbft_current.gif"

Messagepar vals » 10 Nov 2014, 20:19

Bonjour
Je viens d'essayer la manip de mm91.
Effectivement après la manœuvre le fichier windbft_current.gif se transforme en rose des vents.
Plus de camembert.
Il y a donc bien problème.
Mais je vais regarder ce qu'il se passe à la prochaine grande mise à jour de 21h.
Image
Davis VantagePro2 + Wswin32 V2.96.10 + GraphWeather + ftp-uploader. Webcam.

mm91
Participation 6
Participation 6
Messages : 2543
Enregistré le : 31 Mar 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: problème avec création du fichier "windbft_current.gif"

Messagepar mm91 » 10 Nov 2014, 20:36

Ouf !
merci Vals
dans un sens tu me rassure :lol:

Ici une une grande mise à jour ne change rien;
lorsque les deux fichiers sont en rose des vents, la seule façon de revenir à la normale est de fermer et rouvrir Wswin32
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

Avatar du membre
vals
Participation 5
Participation 5
Messages : 825
Enregistré le : 13 Déc 2006, 20:27
Localisation : 69320 Feyzin
Contact :

Re: problème avec création du fichier "windbft_current.gif"

Messagepar vals » 10 Nov 2014, 21:04

Effectivement la grande mise à jour n'a rien changé.
Ce sera bon demain à l'ouverture.
Image
Davis VantagePro2 + Wswin32 V2.96.10 + GraphWeather + ftp-uploader. Webcam.

mm91
Participation 6
Participation 6
Messages : 2543
Enregistré le : 31 Mar 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: problème avec création du fichier "windbft_current.gif"

Messagepar mm91 » 10 Nov 2014, 21:39

Je voudrai bien soumettre moi-même le problème à Werner;

Pouvez-vous me dire si mon anglais est clair ?
(et corrigez-le bien sûr si besoin)
merci.
_____________________________________
There is a problem with the file:

"windbft_current.gif "

My setting:
Internet / Adjustments / Graphics
I chose:
- Create wind distribution graphics in recording mode
- Wind direction + wind force
- Week
- Day

with this setting, both files:
"ddis_current.gif"
and
"windbft_current.gif "

are correctly create.


Now, if I set:
Weather / Wind direction/Wind force
to display wind rose

after that, after the next record, "windbft_current.gif " is create with the same picture than "ddis_current.gif" (with the wind rose for both files).

and to come back good I am obliged to close and open Wswin32 (without display wind rose)
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

Tudgur
Participation 6
Participation 6
Messages : 1710
Enregistré le : 13 Mai 2007, 16:47
Localisation : 29880 Plouguerneau
Contact :

Re: problème avec création du fichier "windbft_current.gif"

Messagepar Tudgur » 13 Nov 2014, 18:53

Plutôt "I have to" ou "I must" au lieu de "I am obliged"
Cordialement.

Tudgur
http://meteo-plouguerneau.fr

mm91
Participation 6
Participation 6
Messages : 2543
Enregistré le : 31 Mar 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: problème avec création du fichier "windbft_current.gif"

Messagepar mm91 » 26 Nov 2014, 17:19

Mail (avec correction Tudgur) envoyé à Werner le 21 novembre 2014.

Je vous tiendrai informés si réponse.
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

mm91
Participation 6
Participation 6
Messages : 2543
Enregistré le : 31 Mar 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: problème avec création du fichier "windbft_current.gif"

Messagepar mm91 » 16 Déc 2014, 10:08

Je n'ai toujours pas reçu de réponse de Werner...
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

Tudgur
Participation 6
Participation 6
Messages : 1710
Enregistré le : 13 Mai 2007, 16:47
Localisation : 29880 Plouguerneau
Contact :

Re: problème avec création du fichier "windbft_current.gif"

Messagepar Tudgur » 17 Déc 2014, 16:34

Ce fut aussi mon cas lorsque je lui ai signalé le bug sur la durée d'ensoleillement :

Un tag peut nous indiquer 60 minutes de soleil au cours de la dernière heure et un autre, simultanément, 9 minutes d'ensoleillement sur au cours des 10 dernières minutes !!!
Cordialement.

Tudgur
http://meteo-plouguerneau.fr

mm91
Participation 6
Participation 6
Messages : 2543
Enregistré le : 31 Mar 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: problème avec création du fichier "windbft_current.gif"

Messagepar mm91 » 22 Déc 2014, 10:45

Message (de rappel) envoyé ce jour:

Hello Werner,
There is this problem on V2.97.13 and on V2.97.8
There is no problem on V2.96.4
I dont try on other Version
regards,
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo


Retourner vers « Bugs »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité