Pb. avec %rainrate%

Forum dédié aux différents bogues découverts ou aux éventuelles améliorations, peut être que Werner nous entendra !
mm91
Participation 6
Participation 6
Messages : 2428
Enregistré le : 31 mars 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: Pb. avec %rainrate%

Message par mm91 » 17 juin 2016, 18:24

vals a écrit :Bonjour
Je viens d'avoir un bel orage un vrai déluge fort et court et j'ai pu suivre en direct live.
C'est bien à la première mesure de pluie que j'ai eu une valeur dans mm/h.
La pluie a commencée entre deux pas de mesures et dès la première mise à jour du curent j'ai eu 1,4 mm intensité 76,8 mm/h.
Peut-être qu'une modif à la main de la pluie ce n'est pas pareil qu'en direct live.
En effet pour avoir 1,4 mm de pluie et une intensité de 76,8 mm/h c'est que la forte pluie a commencée peut de temps avant l'heure de la mesure.
Mais ce n'est qu'une hypothèse. :???:
OK Vals, merci encore pour tes essais.

Il n'y a pas de raison que la manip manuelle ne soit pas valable car Wswin32 ne connaît que ce qu'il y a dans ses fichiers (entré manuellement avec "Edit" ou automatiquement en surveillance de fichier).

Je ne comprends pas bien ton exemple: le temps n'intervient pas, seul le pas de mesure intervient:
s'il y a eu 1.4 mm en 5 mn cela devrait faire 16.8mm/h (et non76.8mm/h)

On parle bien du calcul de Wswin32 et non du calcul Davis ?

De toutes façon, avec une ancienne version le calcul est bien fait (correctement), ici, comme je l'indique ci-dessus.
J'ai très souvent vérifié, c'était toujours juste.

De toutes façons j'ai aussi vérifié avec pluie réelle: %rainrate% est bon avec l'ancienne version et pas bon avec la dernière version. Et ceci avec le même "custom.txt"

Le mystère s'épaissit !

Un vrai challenge pour trouver l'explication…

Proposez-moi des essais à faire.
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

Avatar du membre
vals
Participation 5
Participation 5
Messages : 809
Enregistré le : 13 déc. 2006, 20:27
Localisation : 69320 Feyzin
Contact :

Re: Pb. avec %rainrate%

Message par vals » 17 juin 2016, 19:24

Bonjour
Je viens d'avoir une petite averse.
Voilà ce que j'ai noté.
Heure exacte de la pluie et quantité
19h47'48" 0.2 mm
19h48'21" 0.2 mm
19h48'50" 0.2 mm
19h49'40" 0.2 mm
Puis 0.2 mm entre 19h50 et 19h55
Pour le custom:
19h50 0.8 mm 16.8 mm/h
19h55 1.0 mm 2.6 mm/h
20h00 1.0 mm 1.2 mm/h
20h05 1.0 mm 0.8 mm/h
20h10 1.0 mm 0.0 mm/h
Dans la barre d'affichage de wswin la pluie s'affiche en temps réel.
wswin sait exactement à quelle heure la pluie tombe et ne fait peut-être pas son calcul sur un pas de mesure complet (dans mon cas 5mm) ??
PS: Le fait que je sois en pilotage de la station et toi en surveillance de fichier doit peut-être faire une différence ?
Image
Davis VantagePro2 + Wswin32 V2.96.10 + GraphWeather + ftp-uploader. Webcam.

mm91
Participation 6
Participation 6
Messages : 2428
Enregistré le : 31 mars 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: Pb. avec %rainrate%

Message par mm91 » 18 juin 2016, 17:21

Vals,
peux-tu me dire (après avoir vérifié !) quel est exactement le tag que tu utilises pour afficher:
Intensité: "XX mm/h"
dans ta page custom: http://meteodefeyzin.free.fr/meteo/curent.html
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

Avatar du membre
vals
Participation 5
Participation 5
Messages : 809
Enregistré le : 13 déc. 2006, 20:27
Localisation : 69320 Feyzin
Contact :

Re: Pb. avec %rainrate%

Message par vals » 18 juin 2016, 20:06

Bonjour
Je viens de vérifier:
Pluie dernière heure: %rain1h%
Intensité: %rainrate%
Image
Davis VantagePro2 + Wswin32 V2.96.10 + GraphWeather + ftp-uploader. Webcam.

mm91
Participation 6
Participation 6
Messages : 2428
Enregistré le : 31 mars 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: Pb. avec %rainrate%

Message par mm91 » 19 juin 2016, 08:51

En effet pour avoir 1,4 mm de pluie et une intensité de 76,8 mm/h c'est que la forte pluie a commencée peu(t) de temps avant l'heure de la mesure.
Dans la barre d'affichage de wswin la pluie s'affiche en temps réel.
wswin sait exactement à quelle heure la pluie tombe et ne fait peut-être pas son calcul sur un pas de mesure complet (dans mon cas 5mm) ??
PS: Le fait que je sois en pilotage de la station et toi en surveillance de fichier doit peut-être faire une différence ?
Ces deux citations ont tendance à montrer que le fonctionnement avec la Davis n'est pas le même qu'ici (WS2300 La Crosse et Heavy Weather en surveillance de fichier).

Dans la barre d'affichage de wswin je n'ai pas d'affichage de la pluie en temps réel;
je confirme donc qu'ici Wswin ne connais que la valeur de pluie accumulée pendant cinq minutes (le pas de mesure)
Il n'utilise donc que ça pour faire son calcul d'intensité de pluie.

La VP2 fait aussi un calcul d'intensité (où intervient sans doute le temps); peut-être que Wswin utilise ce calcul pour le combiner à son propre calcul de %rainrate%

Ce qui expliquerait que ça marche chez ceux qui ont une VP2

Dans "ws_variables_en.txt" (du 24/03/2016) on trouve:

Rain rate /hour *%rainrate% V2.98.0 mod (1)

et

--Variables only for VantagePro:
Rainrate/hour *%ws_rainrateh%


Et dans la traduction de Chriss (mais datant d'une vielle version) on trouve:

%rainrate% Intensité de pluie actuelle. Valeur effectué sur 10min si le pas de réception est inférieur à 10min ou sinon le calcul se fait sur le pas de réception.

et

--Tag uniquement pour la vantage
%ws_rainrateh% Intensité de pluie actuelle calculé par la console





Pour le fonctionnement hors VP2:

(1) Que signifie V2.98.0 mod ?
y aurait-il eu un modification du calcul de ce tag depuis la V2.98.0 ?
ce qui expliquerait bien qu'ici ce tag fonctionne parfaitement avec ma version V2.97.8
et ne fonctionne plus avec la V2.98.4. car il y aurait un bug avec cette version (hors fonctionnement avec VP2 qui est différent).



Si vous me confirmez que ça peut être ça, j'écris à Werner.
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

Avatar du membre
vals
Participation 5
Participation 5
Messages : 809
Enregistré le : 13 déc. 2006, 20:27
Localisation : 69320 Feyzin
Contact :

Re: Pb. avec %rainrate%

Message par vals » 19 juin 2016, 09:46

Tous les paramètres de la barre d'affichage varient en temps réel (pluie vent force et direction etc) quand on est en pilotage de la station. La valeur pluie est remise à 0 à chaque pas de lecture.
Effectivement en surveillance de fichiers il faut attendre la fin de la scrutation pour avoir l'affichage sur l'écran.
Quand on rentre une valeur à la main j'imagine qu'elle est prise comme intervenant en fin du pas de lecture.
Pour ma part j'ai toujours était en pilotage direct de la station.
Est-ce que dans les fichiers .dat il y a l'heure précise de chaque événement ou c'est l'heure de la scrutation pour tout ?
Image
Davis VantagePro2 + Wswin32 V2.96.10 + GraphWeather + ftp-uploader. Webcam.

mm91
Participation 6
Participation 6
Messages : 2428
Enregistré le : 31 mars 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: Pb. avec %rainrate%

Message par mm91 » 19 juin 2016, 10:07

vals a écrit :Tous les paramètres de la barre d'affichage varient en temps réel (pluie vent force et direction etc) quand on est en pilotage de la station. La valeur pluie est remise à 0 à chaque pas de lecture.
Effectivement en surveillance de fichiers il faut attendre la fin de la scrutation pour avoir l'affichage sur l'écran.
Quand on rentre une valeur à la main j'imagine qu'elle est prise comme intervenant en fin du pas de lecture.
Pour ma part j'ai toujours était en pilotage direct de la station.
Est-ce que dans les fichiers .dat il y a l'heure précise de chaque événement ou c'est l'heure de la scrutation pour tout ?
Ceci confirme mes suppositions exprimées ci-dessus.

Quand on rentre une valeur à la main j'imagine qu'elle est prise comme intervenant en fin du pas de lecture
peut-être dans ton cas (pilotage station) mais peux-tu entrer des valeurs à la main ?
As-tu essayé ?

Dans mon cas, encore une fois, Wswin32 ne connais que ce qu'il y a dans son fichier (lu toutes les cinq minutes).
L'heure précise a laquelle est arrivée la pluie (entre les pas) n'intervient pas, que ce soit manuellement ou automatiquement (j'ai fais de nombreux essais !)
Est-ce que dans les fichiers .dat il y a l'heure précise de chaque événement ou c'est l'heure de la scrutation pour tout ?
Non ! c'est l'heure ronde (00:00, 00:05, 00:10…) pour tout.

Je fais donc un mail à Werner
(je vous le mettrai ici)
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

mm91
Participation 6
Participation 6
Messages : 2428
Enregistré le : 31 mars 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: Pb. avec %rainrate%

Message par mm91 » 19 juin 2016, 11:03

Voici le mail envoyé à l'instant à Werner.

Le trouvez-vous suffisamment clair ?
_______________________________

Hello Werner,

I have a problem with
%rainrate%
with V2.98.4 version.

I have not VP2 Davis, but WS2300 LaCrosse
(and I know by French forum it's OK with VP2 Davis but it is not the same calculation)


My step is five minutes

for exemple,

if at 12:00 I have 0mm rain
and at 12:05 I have 1mm rain
and at 12:10 I have 0mm rain
%rainrate% = 6mm/h, it's OK

if at 12:00 I have 1mm rain
and at 12:05 I have 1mm rain
and at 12:10 I have 0mm rain
%rainrate% = 12mm/h, it's OK

if at 12:00 I have 1mm rain
and at 12:05 I have 1mm rain
and at 12:10 I have 1mm rain
%rainrate% = 0mm/h, it's not OK


On my PC I have also V2.97.8 version and with this version %rainrate% is always OK
for exemple,
if at 12:00 I have 1mm rain
and at 12:05 I have 1mm rain
and at 12:10 I have 1mm rain
%rainrate% = 18.0mm/h, it's OK


All the other rain calculations are OK (in V2.97.8 and V2.98.4)

In attached file: my "custom.txt"
(and my "courrent.html" here: http://icare.cinq.free.fr/meteo/courrent.html )

I thank you very much.
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

mm91
Participation 6
Participation 6
Messages : 2428
Enregistré le : 31 mars 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: Pb. avec %rainrate%

Message par mm91 » 27 juin 2016, 18:53

Toujours pas de réponse de Werner.

Y aurait-il quelqu'un qui utilise ce tag:
%rainrate%
avec une station autre que Davis ?
Ou une station qui ne calcule pas elle-même un taux de pluie.
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

mm91
Participation 6
Participation 6
Messages : 2428
Enregistré le : 31 mars 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: Pb. avec %rainrate%

Message par mm91 » 01 mars 2017, 14:48

Je viens de faire les essais:

problème résolu avec la nouvelle version de Wswin32: V2.98.6:
(bien que ce ne soit pas signalé dans le "info.txt")

%rainrate"
donne bien (avec ma station La Crosse Ws2300) le taux de pluie (en mm/h) mesuré sur les dix dernières minutes,
pour un pas de 5 minutes (donc 3 mesures) quelque soit la valeur de ces trois mesures.

Je fais un mail à Werner pour lui dire que ça marche.
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

Répondre