Scripts php pour climatologie mensuelle et annuelle

Forum dédié à la mise en ligne de vos données météos relevées avec WsWin.
stefane26
Participation 2
Participation 2
Messages : 108
Enregistré le : 13 sept. 2007, 04:31
Localisation : Montélimar (Drôme)
Contact :

Message par stefane26 » 20 janv. 2008, 18:40

Sur mon PC le dossier est c:\program files\wswin\text et sur le serveur je l'ai placé dans /wswin/noaa, cela est configuré comme cela dans watchdog (et c'est le seul transfert pour l'instant) mais pas de transfert.

Autre question, quelques fichiers images de wswin en 2007 ne sont pas bons : clima_y2007, his_y2007, minmax2007_1, minmax2007_2, rainsun_y2007 et wind_y2007 : comment faire pour les recréer, cela ne marche pas avec "internet - mise à jour graphiques/tableaux

Merci

Avatar du membre
webmaster
Site Admin
Site Admin
Messages : 2610
Enregistré le : 12 déc. 2006, 20:54
Localisation : Rieux 51 FRANCE
Contact :

Message par webmaster » 20 janv. 2008, 18:56

Il faut que tu passes par le menu Météo / Données statistiques.
Tu te mets sur 2007 et tu cliques pour finir sur « Sauvegarder Données Statistiques »

Un transfert toutes les 10 secondes, c’est peut être un peu rapproché non ?
Cordialement

Rieux

Avatar du membre
chriss
Participation 5
Participation 5
Messages : 946
Enregistré le : 31 mai 2007, 16:30
Localisation : Plévenon (22)
Contact :

Message par chriss » 20 janv. 2008, 19:01

stefane26 a écrit :Sur mon PC le dossier est c:\program files\wswin\text et sur le serveur je l'ai placé dans /wswin/noaa, cela est configuré comme cela dans watchdog (et c'est le seul transfert pour l'instant) mais pas de transfert.
OK voici quelque piste:
-le transfert est activé ? Icône vert ?
Tu peux activer momentanément l'écriture du log afin de voir ce qui se passe dans ftp-watchdog, s'il y a une erreur de connexion, de dossier, de fichier ....
-Recréer les noaa via "internet"=>"mise a jour Graphique/tableau..."

stefane26
Participation 2
Participation 2
Messages : 108
Enregistré le : 13 sept. 2007, 04:31
Localisation : Montélimar (Drôme)
Contact :

Message par stefane26 » 20 janv. 2008, 19:11

@webmaster : le transfert toutes les 10 secondes c'était pour mes essais
@Chriss : je vais faire l'essai

stefane26
Participation 2
Participation 2
Messages : 108
Enregistré le : 13 sept. 2007, 04:31
Localisation : Montélimar (Drôme)
Contact :

Message par stefane26 » 21 janv. 2008, 06:18

@Chriss : tu avais raison, le transfert ne se fait que si les fichiers noaa sont mis à jour sur le PC malgrè avoir programé une sauvegarde toutes les 10s

Stephane

Avatar du membre
clement104
participation 3
participation 3
Messages : 222
Enregistré le : 30 juil. 2007, 13:22
Localisation : Mélin, Belgique
Contact :

Message par clement104 » 03 mars 2008, 09:25

Bonjour à tous,

Je remonte ce topic parce que j'ai un problème...

Vous pouvez le voir un cliquant sur les liens

http://www.meteobelgique.net/station/me ... imatom.php
http://www.meteobelgique.net/station/me ... imatoa.php

Je ne vois vraiment pas que faire
:cry:

Merci à vous !

Avatar du membre
vals
Participation 5
Participation 5
Messages : 809
Enregistré le : 13 déc. 2006, 20:27
Localisation : 69320 Feyzin
Contact :

Message par vals » 03 mars 2008, 12:57

Salut Clément.
Est-ce que ça a marché avant ?
Autrement es-tu sûr que ton FAI accepte le php et qu'il est activé ?
@+
Image
Davis VantagePro2 + Wswin32 V2.96.10 + GraphWeather + ftp-uploader. Webcam.

Avatar du membre
clement104
participation 3
participation 3
Messages : 222
Enregistré le : 30 juil. 2007, 13:22
Localisation : Mélin, Belgique
Contact :

Message par clement104 » 03 mars 2008, 13:32

Oui il accepte le php vu que tout est fait en php...

http://www.meteobelgique.net/station/in ... station=65

pareil sur ifrance
http://meteomelin.ifrance.com/Text/climatom.php

Ce n'est pas un problème au niveau du script à mon avis... car quand on va voir plus bas, le tableau est créé mais les données ne sont pas dedans...

:(

Tudgur
Participation 6
Participation 6
Messages : 1688
Enregistré le : 13 mai 2007, 16:47
Localisation : 29880 Plouguerneau

Message par Tudgur » 03 mars 2008, 15:28

Bonjour.

Ce problème survient si les fichiers noaa____.txt ne sont pas "uploadés" en ASCII.
Ceci peut-être paramétré dans ftp-uploader par exemple.
Cordialement.

Tudgur
http://meteo-plouguerneau.fr" onclick="window.open(this.href);return false;

Avatar du membre
clement104
participation 3
participation 3
Messages : 222
Enregistré le : 30 juil. 2007, 13:22
Localisation : Mélin, Belgique
Contact :

Message par clement104 » 03 mars 2008, 16:47

Ca veut dire quoi en ASCII

Perso j'utilise LeapFTP

Avatar du membre
vals
Participation 5
Participation 5
Messages : 809
Enregistré le : 13 déc. 2006, 20:27
Localisation : 69320 Feyzin
Contact :

Message par vals » 03 mars 2008, 17:42

Bonjour.
American Standard Code for Information Interchange.
Quand tu envoies des fichiers vers tes pages perso tu sélectionnes de les transférer soit en mode binaire soit en mode ASCII.
Dans ton cas il faut sélectionner le mode ASCII.
Ça doit se paramétrer dans ton ftp.
Cdlt.
PS: Pas sûr que ça vienne de là car il me semble que si le bon mode n'est pas sélectionné ça donne une suite de chiffres incompréhensibles alors que là il y a des trucs qu'on arrive à lire.
Mais il faut tout de même vérifier ce paramètres dans ton ftp.
Image
Davis VantagePro2 + Wswin32 V2.96.10 + GraphWeather + ftp-uploader. Webcam.

Avatar du membre
clement104
participation 3
participation 3
Messages : 222
Enregistré le : 30 juil. 2007, 13:22
Localisation : Mélin, Belgique
Contact :

Message par clement104 » 03 mars 2008, 19:01

Voilà comment est configuré mon ftp...

Peut-être dois-je ajouter le php?

Image

Bonne soirée!

Avatar du membre
vals
Participation 5
Participation 5
Messages : 809
Enregistré le : 13 déc. 2006, 20:27
Localisation : 69320 Feyzin
Contact :

Message par vals » 03 mars 2008, 19:38

Bonsoir.
C'est bien les *.txt sont envoyés en ASCII.
C'est pour cela que j'avais un petit doute.
Tu peux nous afficher le template txt qui génère ton noaa.
Pour le php tu as pris sur le site de Chriss ?
@+
Image
Davis VantagePro2 + Wswin32 V2.96.10 + GraphWeather + ftp-uploader. Webcam.

Avatar du membre
clement104
participation 3
participation 3
Messages : 222
Enregistré le : 30 juil. 2007, 13:22
Localisation : Mélin, Belgique
Contact :

Message par clement104 » 03 mars 2008, 20:04

Merci Vals!

Les templates ainsi que les rapport sont visivbles à l'adresse quivant:

http://www.meteobelgique.net/station/melin/Text/

Effectivement, j'ai pris les scripts php sur le site de chriss, je les ai légèrement modifié parce que je n'ai pas la mesure de l'ensoleillement...

Bonne soirée...!

Avatar du membre
vals
Participation 5
Participation 5
Messages : 809
Enregistré le : 13 déc. 2006, 20:27
Localisation : 69320 Feyzin
Contact :

Message par vals » 03 mars 2008, 21:19

Regarde Clément.
J'ai mis tes données en txt sur cette page.
C'est tout bon.
Il faudrait peut-être réinstaller tes fichiers php tu dois avoir un pb de ce coté là.
Image
Davis VantagePro2 + Wswin32 V2.96.10 + GraphWeather + ftp-uploader. Webcam.

Répondre