Scripts php pour climatologie mensuelle et annuelle

Forum dédié à la mise en ligne de vos données météos relevées avec WsWin.
Répondre
filou70
Participation 0
Participation 0
Messages : 25
Enregistré le : 04 mai 2007, 16:45
Contact :

Message par filou70 » 11 oct. 2007, 17:56

chriss a écrit : Si tu veux que je regarde tout ca, envoie moi un noaa et ton fichier php.
Bonsoir Christophe, voila je t'ai envoyé un mail avec les explications et les fichiers, merci de ton aide.
Station météo Mebus TE923 et webcam de Soumagne, entre Liège et Verviers, Belgique

Image

Avatar du membre
webmaster
Site Admin
Site Admin
Messages : 2611
Enregistré le : 12 déc. 2006, 20:54
Localisation : Rieux 51 FRANCE
Contact :

Message par webmaster » 25 oct. 2007, 17:54

Pour info une modification du code JS proposé par JackT.
Le repérage de l’emplacement de la souris est défaillant et plante l’affichage du graphique.

http://rieux-marne.net/meteo/filesearchhover.txt

Modifier l’extension TXT en JS et modifier la ligne 8 pour ne plus pointer vers le site de JackT.
Cordialement

Rieux

filou70
Participation 0
Participation 0
Messages : 25
Enregistré le : 04 mai 2007, 16:45
Contact :

Message par filou70 » 26 oct. 2007, 22:41

Bonsoir,

Pour ma part c'est corrigé, merci.
Station météo Mebus TE923 et webcam de Soumagne, entre Liège et Verviers, Belgique

Image

Avatar du membre
webmaster
Site Admin
Site Admin
Messages : 2611
Enregistré le : 12 déc. 2006, 20:54
Localisation : Rieux 51 FRANCE
Contact :

Message par webmaster » 27 oct. 2007, 08:56

Bonjour,

Et bien ça n’a pourtant pas l’air !
En mensuel tu n’as pas d’affichage, en annuel les graphiques sortent de la page…..
Cordialement

Rieux

Avatar du membre
vals
Participation 5
Participation 5
Messages : 814
Enregistré le : 13 déc. 2006, 20:27
Localisation : 69320 Feyzin
Contact :

Message par vals » 27 oct. 2007, 09:45

webmaster a écrit :Pour info une modification du code JS proposé par JackT.
Le repérage de l’emplacement de la souris est défaillant et plante l’affichage du graphique.

http://rieux-marne.net/meteo/filesearchhover.txt

Modifier l’extension TXT en JS et modifier la ligne 8 pour ne plus pointer vers le site de JackT.
Effectivement, maintenant les graph ne sortent plus de la page.
Impec. :lol:
Image
Davis VantagePro2 + Wswin32 V2.96.10 + GraphWeather + ftp-uploader. Webcam.

filou70
Participation 0
Participation 0
Messages : 25
Enregistré le : 04 mai 2007, 16:45
Contact :

Message par filou70 » 27 oct. 2007, 10:40

webmaster a écrit : Et bien ça n’a pourtant pas l’air !
En mensuel tu n’as pas d’affichage, en annuel les graphiques sortent de la page…..
Bonjour,

Je voulais juste dire que le lien vers JackT était supprimé.
Pour le graph mensuel, les graphiques n'apparaissent que pour le jour en cours,
et c'est voulu.
Sinon pour les graphs qui débordent, j'ai pas encore essayé le nouveau script.

A bientôt.
Station météo Mebus TE923 et webcam de Soumagne, entre Liège et Verviers, Belgique

Image

Avatar du membre
clement104
participation 3
participation 3
Messages : 222
Enregistré le : 30 juil. 2007, 13:22
Localisation : Mélin, Belgique
Contact :

Message par clement104 » 31 oct. 2007, 08:43

Bonjour,

Chez moi, je pense que le climatom.php déconne, est-ce normale qu'il soit comme ça (photo)
Image

Est-il possible de modifier le code php de climatoa.php car je n'utilise pas la fonction année séparer?

Merci!

Avatar du membre
webmaster
Site Admin
Site Admin
Messages : 2611
Enregistré le : 12 déc. 2006, 20:54
Localisation : Rieux 51 FRANCE
Contact :

Message par webmaster » 31 oct. 2007, 09:39

C’est le fichier template_noaa_m.txt qui n’est pas bon !
Le fait que les années soit séparées ou non pour moi ne change rien puisque le code PHP puise ses données dans les fichiers TXT qui se trouvent au même endroit.
Cordialement

Rieux

Avatar du membre
clement104
participation 3
participation 3
Messages : 222
Enregistré le : 30 juil. 2007, 13:22
Localisation : Mélin, Belgique
Contact :

Message par clement104 » 31 oct. 2007, 09:43

webmaster a écrit :C’est le fichier template_noaa_m.txt qui n’est pas bon !
Pourtant j'ai copié celui que fournissait JackT ! :?

Avatar du membre
webmaster
Site Admin
Site Admin
Messages : 2611
Enregistré le : 12 déc. 2006, 20:54
Localisation : Rieux 51 FRANCE
Contact :

Message par webmaster » 31 oct. 2007, 10:08

Et bien as-tu refait une mise à jour suite à cela ?
Il faut générer de nouveau la totalité des fichiers !
Cordialement

Rieux

tifidus
Participation 0
Participation 0
Messages : 6
Enregistré le : 29 sept. 2007, 16:41
Contact :

Message par tifidus » 31 oct. 2007, 18:37

bonsoir,

c'est un problème de virgule à la place du point.

il faut mettre ce code dans ton template_noaa_m.txt :

Code : Tout sélectionner

%alwaysseppoint_on%
exemple :

Code : Tout sélectionner

<customfile>  
       Climatologie mensuelle pour %monthtxt% %ws_year%
%alwaysseppoint_on%

Avatar du membre
clement104
participation 3
participation 3
Messages : 222
Enregistré le : 30 juil. 2007, 13:22
Localisation : Mélin, Belgique
Contact :

Message par clement104 » 01 nov. 2007, 07:45

VOilà maintenant ce qui s'affige qque je charge la page climatom.php
Fatal error: Call to undefined function replace() in /www/sites/1/ifrance.com/c/o/*******-**********/site/climatom.php on line 103
Que dois-je faire?

Avatar du membre
clement104
participation 3
participation 3
Messages : 222
Enregistré le : 30 juil. 2007, 13:22
Localisation : Mélin, Belgique
Contact :

Message par clement104 » 01 nov. 2007, 10:46

Probléme réglé!

Maintenant, il fut régler le problème de couleur! J'ai tout qui s'affiche de la même couleur*:Image

*: Je précise que ce n'est que pour la climatologie mensuelle que j'ai ce problème des couleurs!

Merci!

Avatar du membre
chriss
Participation 5
Participation 5
Messages : 948
Enregistré le : 31 mai 2007, 16:30
Localisation : Plévenon (22)
Contact :

Message par chriss » 01 nov. 2007, 11:27

Comme te l'as dis tifdus, c'est un problème de virgule !
Le séparateur décimal doit être le point et non la virgule.
Ouvre ton fichier template_noaa_m.txt. Normalement la troisiéme ligne devrait être vide.
Place le tag suivant dans cette ligne: %alwaysseppoint_on%
Enregistre et refais une mise a jour des noaa et rebalance-les sur ton site.
Ca devrais marcher.

dudu
Participation 0
Participation 0
Messages : 8
Enregistré le : 04 nov. 2007, 20:34

Message par dudu » 11 nov. 2007, 22:34

j'ai réussi a faire apparaitre les fichier php
par contre j'ai un problème avec les pictos

http://www.premiumorange.com/meteobastia/mensuel.php

Répondre