%ws_uvtext%

Forum destiné aux problèmes de Tags, recherche d’une fonction, d’un calcul, Tag qui parait ne pas fonctionner, du Tag et rien que du Tag !
Répondre
doubleau
Participation 2
Participation 2
Messages : 137
Enregistré le : 12 févr. 2010, 18:41
Localisation : Mussidan (Dordogne)
Contact :

%ws_uvtext%

Message par doubleau » 28 déc. 2017, 21:01

Le tag %ws_uvtext% retourne : none, minimal, low, moderate, high, veryhigh. Comment obtenir le résultat du tag en français et pas en anglais ?
Merci

mm91
Participation 6
Participation 6
Messages : 2439
Enregistré le : 31 mars 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: %ws_uvtext%

Message par mm91 » 31 déc. 2017, 17:22

Dans le fichier "ws_varable" (en français) il est indiqué:

Tout les tags ayant le signe "#" devant signifie que le text donné par le tag peut être affiché dans différentes langues. Il suffit de placer le numéro de la langue correspondante entre les crochet du tag ( à la place du "x").
Exemple: %suntxt[0]% va afficher la couverture nuageuse en allemand. %suntxt[2]% lui va l'afficher en français.
Numéros associés au langues:
x=0 Allemand
x=1 Anglais
x=2 Français
x=3 Italien
x=4 Tchèque
x=5 Hollandais
x=6 Espagnol



Or je constate que le tag:

%ws_uvtext% : Indice UV en texte => none, minimal,low, moderate, high, veryhigh
n'a pas de "#", donc ce tag est obligatoirement en anglais !


Par contre il est tout à fait possible de remplacer un texte (par exemple en anglais) par un autre (par exemple en français), avec la fonction:

%ws_setmem[1]=%ws_replacestr….

(je l'ai fait pour certains textes dans ma page http://icare.cinq.free.fr/meteo/courrent.html )
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

Répondre